We can't wait to see you at Booth #1018 at Automation Fair® 2019 Click here to register.
Knowledge Base / Gateways / AN-X2 / Remote IO HMI

Why is the FTView application not getting any data from the AN-X2-AB-DHRIO Gateway running the RIO HMI firmware?

Search KB

Categories

There are several reasons as to why the FactoryTalk View application may not be able to communicate to the AN-X2-AB-DHRIO gateway when running the AB Remote I/O HMI firmware.  This article will discuss some of the most common reasons as to why the communication is not occurring successfully.

First scenario:

     When configuring a new application the shortcut was not configured correctly in FactoryTalk View:

1) Right click on Ethernet driver and select add new device

Add Device

2)  Expand and browse the NetENI connected PCCC devices folder, and then expand and browse the PLC 5 processors folder and select the second processor which should be the L40C.

L40C

3) Enter in the IP Address of the AN-X2-AB-DHRIO gateway.

4) Finish the shortcut configuration, and then select the copy from design time to run time button.

Second Scenario:

     The shortcut is configured properly in FactoryTalk View, but it has not been copied from design time to run time.  To resolve this issue select the copy from design time to run time button, and then test the application locally to verify that it is able to communicate to the gateway.

Third scenario:

    The gateway does not have a configuration file loaded into it, or is not running the correct firmware.  To validate this open the web page for the AN-X2-AB-DHRIO gateway and verify that it is running the AB HMI firmware under the Administration area:

Admin

Then confirm that the correct configuration file is loaded by selecting View Configuration File under the Automation Network area.

ConfigFile