Knowledge Base / Rockwell In-chassis / SLC / MVI46 Series

I am using a ProSoft MVI46 solution and I am getting a Fault Message that says, "Specialty I/O Module in Slot x has not responded within the time limit." What can cause this?

Search KB

Categories

This particular fault is infrequent but common on the SLC platform.  Without getting into a lot of boring details, it has to do with critical, sub-millisecond timing of backplane messages.  ProSoft has worked closely with Rockwell Automation to minimize to the greatest extent possible the occurrances of this fault.  However, users may encounter it, from time to time.

Usually, all that is need to recover from this condition is to re-boot the SLC processor by doing a power cycle of the rack.  You can also sometimes clear the fault by going from RUN to PROGRAM mode and back to RUN or REM RUN.  If the MVI46 module continues to cause this fault, please check for the following:

1.  Be sure the BATT LED is Off.  If it is On Red, it can cause this fault.  To correct the problem, leave the MVI46 module in a powered-up chassis until BATT LED goes off.  This could be for as little as a few minutes to as much as a few hours.  If the module is left in a powered-up rack for a solid 24-hour period and the BATT LED is still on, the module must be returned to ProSoft for repair.  The battery is NOT user-replacable in the field.

2.  Check the Setup Jumper.  Be sure it is installed on only one of the two pins and not installed to short both pins.  Setup Mode is used only for updating module firmware and only when directed to do so by ProSoft Technical Support Engineers.  If the jumper is installed to short both pins during normal operation, it might cause this fault.

3.  In the module BIOS settings screen, there is a parameter called "Console on Port".  The options for this parameter are "Enabled" and "Disabled".  The factory default setting is "Disabled" and should be left this way.  If you change the setting to "Enabled" and you begin to get the above fault, you will need to go back into the BIOS and set the parameter back to "Disabled."  If you don't know how to get into the BIOS, then don't try.  If you suspect this may be the problem, call ProSoft Technical Support for assistance in checking and/or correcting this issue.

4.  Sometimes, moving the module to another slot in the chassis, preferrably closer to the SLC processor may eliminate the fault.  The fault may also occur due to a hardware problem within the chassis itself, the SLC CPU, or the ProSoft module.  Swapping out SLC, chassis and module may eliminate the problem.

If none of these suggestions correct the problem, please contact ProSoft Technical Support for further assistance.